想下个scrapy去加深自己的爬虫功力,结果在pip3.4 install scrapy 的时候遇到问题了

首先在执行时输出了这句

Requirement already satisfied (use --upgrade to upgrade)

也就是需要去更新

pip3.4 install --upgrade scrapy

此时弹出错误

ERROR: b'/bin/sh: xslt-config: command not foundn'

通过参考 点击此处跳转 得到了启发

先执行 whereis xslt-config 查看是否有此命令

发现 xslt-config: ,也就是冒号后面是空的

执行
yum install libxslt-devel

再次查看
whereis xslt-config

发现此时有了数据了

再执行
pip3.4 install xml

pip3.4 install scrapy

以上是Linux的,Windows下要如何解决呢?

stackoverflow

这个方法也就是去官方下载 whl 通过 pip install 安装就成功了

想下个scrapy去加深自己的爬虫功力,结果在pip3.4 install scrapy 的时候遇到问题了

首先在执行时输出了这句

Requirement already satisfied (use --upgrade to upgrade)

也就是需要去更新

pip3.4 install --upgrade scrapy

此时弹出错误

ERROR: b'/bin/sh: xslt-config: command not foundn'

通过参考 点击此处跳转 得到了启发

先执行 whereis xslt-config 查看是否有此命令

发现 xslt-config: ,也就是冒号后面是空的

执行
yum install libxslt-devel

再次查看
whereis xslt-config

发现此时有了数据了

再执行
pip3.4 install xml

pip3.4 install scrapy

以上是Linux的,Windows下要如何解决呢?

stackoverflow

这个方法也就是去官方下载 whl 通过 pip install 安装就成功了